Email Templates – SEND Button Missing

Incident Report for Visp

Resolved

Update: Email Template Workflow Change

Upon investigation, we confirmed that the SEND button was not missing due to an issue, but rather due to a new Email Template workflow and UI improvement introduced for sending mass emails.

Updated Workflow for Sending Emails

1.Click the “+” icon located in the upper-right corner of the VISP app.

2. Select Send Message.

3. Choose an Email Template.

4. Ensure the following required fields are completed:

* Filtered List (Recipients)

*From

*Subject

5. Once all required fields are filled in, the SEND button will become available.

6. Click SEND to proceed.

For detailed instructions, please visit:
👉 https://docs.google.com/document/d/1eQy7c0ES8_d398tEv84gzUek8Q_06c6Coks3Mx_rZUE/edit?tab=t.0

If you have any questions or need assistance, please contact the Client Success team
Posted Feb 07, 2026 - 00:48 UTC

Investigating

We are currently investigating an issue where the SEND button is missing across all email templates. This may prevent emails from being sent as expected.
Our team is actively working on a fix and will provide updates as soon as more information is available.
Posted Feb 06, 2026 - 22:41 UTC
This incident affected: VISP.