Upcoming Invoice showing incorrect dates
Incident Report for Visp
Resolved
The team has implemented a fix, and now all Upcoming Invoices show the correct date. Feel free to reach out to the Visp Client Success team if you have additional questions or concerns regarding this case.
Posted Apr 23, 2024 - 15:01 UTC
Investigating
We have received reports that the Upcoming Invoices show incorrect dates, such as Dec 2025 or 2026. The team is already investigating this issue. We will provide updates as soon as possible.
Posted Apr 22, 2024 - 20:37 UTC
This incident affected: VISP.