Service Degradation – Visp Application Slowness

Incident Report for Visp

Resolved

The issue causing slowness and loading errors in the Visp application has been resolved. The application is now operating normally.

If you continue to experience any issues, please contact the Client Success Team.
Posted Jan 27, 2026 - 00:58 UTC

Investigating

We are currently experiencing slowness and loading issues within the VISP application. Some users may encounter an error message stating “Something went wrong” and may be unable to load the application.

Our engineering team is actively investigating the issue and working to restore normal performance as quickly as possible.

We will provide updates as more information becomes available. Thank you for your patience.
Posted Jan 26, 2026 - 23:31 UTC
This incident affected: VISP.