Users Unable to View Tickets via the Service Desk

Incident Report for Visp

Resolved

The issue affecting the display of service desk tickets has been successfully resolved. Ticket data filtered by technician is now displaying correctly.

Thank you for your patience as we worked to address this.

VISP Support Team
Posted Jun 18, 2025 - 12:32 UTC

Investigating

We are actively investigating an issue affecting the display of service desk tickets across user accounts. Several ISPs have reported that certain users are unable to load or view their tickets in the Service Desk.

Updates will be posted as soon as they are available.
Posted Jun 17, 2025 - 20:07 UTC
This incident affected: VISP.