Searching by Address May Return Too Many Results

Incident Report for Visp

Resolved

The issue causing address searches to return all accounts or an unusually high number of results has been resolved. Address searches are now returning the expected, specific results. Thank you for your patience while our team investigated and implemented the fix.
Posted Dec 18, 2025 - 10:51 UTC

Investigating

We’re aware that searches by address are currently returning all accounts or an unusually high number of results, rather than just the specific matches expected. Our team is actively investigating the issue and working on a resolution. We’ll provide updates as soon as more information or a fix is available.
Posted Dec 17, 2025 - 21:01 UTC
This incident affected: VISP.