Issue When Adding New Equipment via the IRM Panel

Incident Report for Visp

Resolved

The issue affecting the ability to add new equipment via the IRM panel has cleared, and the feature is now working as expected. We’ll continue to monitor the system, but no further impact is anticipated.

Thank you for your patience.
Posted May 05, 2026 - 22:10 UTC

Investigating

We received a report about an issue when adding new equipment via the IRM panel. Currently, clicking the plus sign to add new equipment in the equipment section of the IRM results in an error that displays a blank or white screen.

If the issue continues after a regular refresh, try performing a clean or hard refresh.

-On Windows: Hold Control and press F5, then wait for the page to reload.
-On Mac: Hold Command + Shift + R to achieve the same effect.

This forces the browser to reload the page and clear cached content, which often resolves display or loading errors.

The team is still investigating this issue and will share updates as they become available.
Posted May 05, 2026 - 15:50 UTC
This incident affected: VISP.