Service Outage: VISP.net App Down

Incident Report for Visp

Postmortem

Post-Incident Report: visp.net App Outage

Date of Incident: November 7, 2025
Duration: Approximately 1 hour (5:52 AM – 6:55 AM PST)
Status: Resolved
Impact Level: Critical
Affected Systems: VISP.net App, vBOSS, UBO, Website, RADIUS

Summary

On November 7, 2025, the VISP.net app and connected services became temporarily unavailable. Users encountered the error message:

“We’re sorry, but something went wrong.”

The outage originated from the primary database, which stopped responding during routine background system operations. VISP’s engineering and DevOps teams quickly identified the issue and restored all systems. No data loss or corruption occurred, and services have remained stable since recovery.

Reason for Outage (RFO)

The outage occurred when multiple automated system tasks ran at the same time, placing a temporary heavy load on the main database. This caused it to pause and stop responding to new requests, which in turn made VISP.net and related systems unavailable.

After confirming that the system was unresponsive, VISP engineers performed a manual database restart, which restored service across all platforms.

Why it happened

  • Several maintenance and billing tasks overlapped in timing.
  • This simultaneous activity overwhelmed the database’s ability to process new connections.

Resolution

  • The database was manually rebooted through AWS.
  • Systems were verified and confirmed stable after recovery.

Duration

  • Approximately 1 hour of service disruption.

Root Cause Analysis (RCA)

Technical Root Cause: The outage was caused by a rare internal database lock condition that occurred under a high volume of concurrent write operations from overlapping automated maintenance tasks. During this period, the database’s internal processes became blocked, halting query execution and preventing new connections.

Once the condition was confirmed, DevOps initiated a manual reboot of the database instance to clear the stalled state and reinitialize services.

Key Facts:

  • Occurred at ~5:52 AM PST during automated billing and maintenance cycles.
  • Affected systems: VISP.net App, vBOSS, UBO, Website, and RADIUS authentication.
  • Fully restored by ~6:55 AM PST.
  • No data loss or integrity issues detected.

Preventive Measures

To strengthen reliability and prevent a recurrence, VISP has implemented and scheduled the following actions:

  1. Cron Job Optimization – Adjusting and staggering scheduled maintenance tasks to prevent simultaneous high-load operations.
  2. Database Engine Upgrade – Planning an upgrade to a newer MySQL version to improve concurrency handling and stability.
  3. System Isolation – Moving RADIUS functions to a dedicated database to reduce load on the primary system.
  4. Enhanced Monitoring – Expanding real-time alerts for database performance, query latency, and connection stalls to detect early warning signs.

Conclusion

This incident was the result of an unusual overlap of scheduled background activities that temporarily overloaded the main database. VISP responded immediately, restored full operations, and verified that no data was lost.

We sincerely apologize for the disruption and appreciate your patience and trust as we continue to enhance the stability and reliability of VISP’s platform.

Posted Nov 07, 2025 - 13:51 UTC

Resolved

The issue that caused the VISP.net app to display the error “We’re sorry, but something went wrong” has been resolved. All services are now fully operational.

Our engineering team identified and corrected the root cause, and systems are being closely monitored to ensure continued stability.

We appreciate your patience while we worked through this issue. A detailed post-mortem report will be shared once it’s available.

— The VISP Team
Posted Nov 06, 2025 - 17:28 UTC

Update

The team is currently investigating the root cause of the issue and will share a post-mortem report as soon as it becomes available. We are actively monitoring all services to ensure stability. If you are still experiencing issues or have additional concerns, feel free to reach out to your VISP Client Success team via chat, phone, or email.
Posted Nov 06, 2025 - 14:43 UTC

Monitoring

We received an update that the Visp Web App should now be accessible again. Affected services are now recovering, and the team is continually monitoring the situation. Additional updates will be posted as soon as they are available.
Posted Nov 06, 2025 - 14:33 UTC

Investigating

Priority: Critical

We’re aware that users are currently unable to access the VISP.net app, encountering the error message:

“We’re sorry, but something went wrong.”

Our team is actively investigating the cause and working to restore full functionality as quickly as possible. This issue is our highest priority at the moment.

We’ll post an update as soon as we have more information.

Thank you for your patience and understanding.
Posted Nov 06, 2025 - 14:14 UTC
This incident affected: VISP.