Error When Saving Invoices

Incident Report for Visp

Resolved

This issue has now been resolved. We appreciate the reports provided. They've been very helpful for the team to identify the root cause and update the system.
Posted Sep 16, 2025 - 14:43 UTC

Investigating

We've received reports about an error that appears when saving invoices. This has been escalated, and the team will investigate. Updates will be provided as soon as they are available.
Posted Sep 16, 2025 - 14:12 UTC
This incident affected: VISP.