Issue with Manually Adding New Customers and System Latency – Investigation Underway

Incident Report for Visp

Resolved

The team posted an update. The issue has been resolved, and the team will continue to monitor the situation.

We appreciate your patience throughout this process.
Posted Apr 08, 2026 - 16:13 UTC

Investigating

We have received reports regarding an issue with manually adding new customers in Visp. Some users have also experienced latency affecting the ticket creation process.

The developers have been notified and are actively investigating the matter. We will provide updates as soon as more information becomes available.
Posted Apr 08, 2026 - 15:50 UTC
This incident affected: VISP.