Intermittent Payment and Card Processing Issues (RESOLVED)

Incident Report for Visp

Resolved

This incident has been resolved.
Posted May 06, 2025 - 20:00 UTC

Monitoring

UPDATE: We are pleased to report that the intermittent issues affecting the adding of new cards and the processing of payments within Visp have been successfully resolved. Our development team addressed the problem promptly.

Current Status:

The root cause of the discrepancy between merchant gateway approval and payment recording in Visp has been identified and fixed. We are now in the process of validating accounts that encountered errors during the incident.

Next Steps:

Our team is reviewing all affected accounts reported to ensure no transactions were lost or misrecorded. The Client Success team has been notified and is prepared to assist users who experienced issues. Any cases requiring further attention will be escalated to the appropriate teams for resolution. If you experienced any problems with adding new payment methods or processing transactions during this incident, please contact your Client Success Team. They are equipped to assist you or escalate if necessary.

We apologize for any inconvenience this may have caused and appreciate your patience as we worked to resolve the issue. Thank you for your understanding and continued trust in Visp.
Posted May 06, 2025 - 16:20 UTC
This incident affected: VISP.