The issue that caused IPpay payment attempts to return an “INTERNAL SERVER ERROR” message has been resolved. ISPs have confirmed that payment processing is now functioning normally.
Payments can now resume as usual. Our team will be conducting an audit on the affected areas to ensure data consistency and accuracy.
We are also working with our partners to finalize the root cause analysis (RCA), which will be shared once available.
Thank you for your patience and understanding.
Posted Jul 16, 2025 - 15:13 UTC
Update
We are currently investigating an issue affecting IPpay payments. While processing, it may appear to be "loading" and eventually show an "INTERNAL SERVER ERROR" message.
Please refrain from attempting payment processing through IPpay at this time to avoid duplicate or failed transactions. A fix is currently underway, and we’ll provide updates as soon as possible.
Thank you for your understanding and patience.
Posted Jul 16, 2025 - 14:05 UTC
Investigating
We are currently investigating an issue where payment attempts via IPpay are returning an "INTERNAL SERVER ERROR" message. Our team is actively working with our payment gateway partner to identify the root cause and resolve the issue as quickly as possible.
We recommend holding off on payment processing through IPpay until the issue is resolved. We will provide updates here as soon as more information becomes available.